1044 Shopping in Mars 25 ☆☆☆

github地址:https://github.com/iofu728/PAT-A-by-iofu728
难度:☆☆☆
关键词:dp(只能拿23分),快速查找

题目

1044.Shopping in Mars (25)
Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

1.Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
2.Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
3.Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).
Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has to pay. Then the next line contains N positive numbers D1DN (Di<=103 for all i=1, …, N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print “i-j” in a line for each pair of i <= j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output “i-j” for pairs of i <= j such that Di + … + Dj > M with (Di + … + DjM) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:
16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:
1-5
4-6
7-8
11-11

Sample Input 2:
5 13
2 4 5 7 9

Sample Output 2:
2-4
4-5

大意

在火星上钱是串在一起的,要付钱就得选择连续一段钱,求最合适的付款方式。

思路

  1. 一看这问题,下意识以为就是求最接近某值连续和,一想这不是动态规划吗?
    按照dp思路,确定递归式子,取左右指针为p=0,q=0:
    当sum==m,输出,并++q;
    当sum>m,先判断是不是离m更近(与maxmin比较),再判断p,q是否紧挨着,紧挨着就p,q全++,否则++p,更新sum;
    当sum<=m,++q,更新sum
  2. 但按照上述思路,一个测试点超时过不去只有23分(好像也足够了,hhh)
    所以先想怎么能够优化,考虑到sum在运算过程中都是做累加工作,如果一开始dis就代表和,那么会减少点计算量。
  3. 整个过程,用了一个for'循环,一次while’循环,产生时间复杂度的主要在循环。
  4. 第一个循环不能避免,所以一开始考虑边录入边处理,思来想去好像没思路。
  5. 最后从后一个循环入手,考虑dis数组单增的特性,实际上我们求得就是每一个左指针p对应的右指针q的查找工作。

code

#include <iostream>
#include <vector>
using namespace std;
const int INF = 0x3fffffff;
int n, m;
struct node {
  int sum, p, q;
};

int main(int argc, char const *argv[]) {
  int maxmin = INF, p = 0, q = 0, sum = 0, temp = 0;
  bool vis = false;
  vector<node> v;
  cin >> n >> m;
  int dis[n + 1];
  getchar();
  for (int i = 1; i <= n; ++i) {
    cin >> temp;
    sum += temp;
    dis[i] = sum;
  }
  getchar();
  sum = 0;
  dis[0] = 0;
  while (p <= n && q <= n && p <= q) {
    if (sum == m) {
      cout << p + 1 << "-" << q << endl;
      vis = true;
      ++q;
      if (q <= n) {
        sum = dis[q] - dis[p];
      }
    } else if (sum < m) {
      //            cout<<"*"<<sum<<" "<<p<<" "<<q<<endl;
      ++q;
      if (q <= n) {
        sum = dis[q] - dis[p];
      }
    } else {
      if (sum <= maxmin) {
        //              cout<<"--";
        if (sum < maxmin) {
          v.clear();
        }
        node temp;
        temp.p = p, temp.q = q, maxmin = sum, temp.sum = sum;
        v.push_back(temp);
      }
      if (p == q - 1) {
        //              cout<<"??";
        ++p;
        ++q;
      } else {
        //              cout<<"<>";
        ++p;
      }
      sum = dis[q] - dis[p];
    }
  }
  if (!vis) {
    for (int i = 0; i < v.size(); ++i) {
      cout << v[i].p + 1 << "-" << v[i].q << endl;
    }
  }
  return 0;
}
//#include <iostream>
//#include <vector>
// using namespace std;
// vector<int> sum, resultArr;
// int n, m;
// void Func(int i, int &j, int &tempsum) {
//    int left = i, right = n;
//    while(left < right) {
//        int mid = (left + right) / 2;
//        if(sum[mid] - sum[i-1] >= m)
//            right = mid;
//        else
//            left = mid + 1;
//    }
//    j = right;
//    tempsum = sum[j] - sum[i-1];
//}
// int main() {
//    scanf("%d%d", &n, &m);
//    sum.resize(n+1);
//    for(int i = 1; i <= n; i++) {
//        scanf("%d", &sum[i]);
//        sum[i] += sum[i-1];
//    }
//    int minans = sum[n];
//    for(int i = 1; i <= n; i++) {
//        int j, tempsum;
//        Func(i, j, tempsum);
//        if(tempsum > minans) continue;
//        if(tempsum >= m) {
//            if(tempsum < minans) {
//                resultArr.clear();
//                minans = tempsum;
//            }
//            resultArr.push_back(i);
//            resultArr.push_back(j);
//        }
//    }
//    for(int i = 0; i < resultArr.size(); i += 2)
//        printf("%d-%d\n", resultArr[i], resultArr[i+1]);
//    return 0;
//}

累计访问量: | 昨日访问量: | 昨日爬虫数:
Gunjianpan © 2017 - 2020 Power by VuePress & iofu728/blog